2012-04-12 1 views
6

Sto provando a eseguire il blocco appunti IPython in Vista. Credo di aver installato tutte le dipendenze necessarie (elencate here) con easy_install. IPython funziona bene. Ma quando provo a eseguire il blocco note su IPython, tutto si avvia bene, ma poi il kernel muore quando provo a fare qualcosa. Ottengo il seguente errore di confusione:Errore Pyzmq nel notebook IPython

Traceback (most recent call last): 
    File "<string>", line 1, in <module> 
    File "C:\Python27\lib\site-packages\ipython-0.11-py2.7.egg\IPython\zmq\__init__.py", line 25, in <module> 
    minimum_pyzmq_version, pyzmq_version)) 
ImportError: IPython.zmq requires pyzmq >= 2.1.4, but you have 2.1.11 

2.1.11> = 2.1.4 quindi non sono sicuro di quale sia il problema. 2.1.11 è l'ultima versione di pyzmq (here è la pagina del progetto).

[Aggiornamento: Grazie @ThomasK. Stavo già eseguendo IPython 0.12 ma ho eseguito easy_install --upgrade su IPython e pyzmg e l'ho risolto.]

+0

Il traceback dice 'ipython-0.11-py2.7.egg', quindi ci deve essere stata un'installazione di IPython 0.11 coinvolta in qualche modo. –

risposta

1

Questo bug è stato corretto in IPython 0.12, quindi è necessario eseguire l'aggiornamento. Hai bisogno di 0.12 per eseguire il notebook, comunque.

In caso di problemi durante l'aggiornamento, provare a eliminare la cartella in cui è installato IPython 0.11 e quindi installare di nuovo con easy_install.

Problemi correlati