2016-03-16 3 views
5

Fino a due giorni fa tutto andava bene con la mia macchina, poi mi è capitato di creare manualmente ffmpeg e installato le sue dipendenze anche manualmente. Ora all'interno di un NumPy virtualenv carico sta venendo a mancare con questo errore:Installazione numpy incasinata - `GFORTRAN_1.4 'non trovata bug

ImportError: /home/koustuv/miniconda/lib/libgfortran.so.3: version `GFORTRAN_1.4' not found (required by /usr/lib/liblapack.so.3)

ho provato nella mia normale installazione Conda senza virtualenv e si sta lavorando bene, ma all'interno di una nuova virtualenv (anche con l'impostazione posizione pitone al Ubuntu uno diverso da miniconda uno) numpy non riesce a importare con questo strano errore. Ho provato ad installare gfortan ma è già nel pacchetto più recente. Per favore aiuto! tutte le assegnazioni sono bloccati :(

risposta

5

Una soluzione che ha funzionato per me è:.!

conda remove libgfortran 
conda install libgcc --force 

Se volete maggiori dettagli, controllare this issue, dove ho trovato la soluzione

+0

grazie a lot questo ha risolto il problema :) –

+0

Ha funzionato anche per me: codice Theano implementato in Jupyter notebook lanciato nell'ambiente virtuale Anaconda/Python 3.5 :-D –

+0

Questo ha risolto il problema anche per me (usando Anaconda con Python 2.7 su un notebook Jupyter). Grazie. – chronosynclastic