2016-07-15 36 views
6

Quando provo a distribuire il file jar sul server in quel momento viene distribuito correttamente e quindi eseguo il file startup.sh dopo che l'applicazione di avvio di primavera avvia l'esecuzione ma dopo l'esecuzione di questi ultimi il server è non risponde più.L'avvio a molla si interrompe dopo l'avvio sul server

[2016-07-15 11:01:38.714] boot - 14956 INFO [main] --- TomcatEmbeddedServletContainer: Tomcat started on port(s): 8084 (http) 
[2016-07-15 11:01:38.723] boot - 14956 INFO [main] --- Application: Started Application in 64.717 seconds (JVM running for 67.138) 
[2016-07-15 11:01:44.688] boot - 14956 INFO [Thread-4] --- AnnotationConfigEmbeddedWebApplicationContext: Closing org.springframework.boot[email protected]64375c2a: startup date [Fri Jul 15 11:00:38 EDT 2016]; root of context hierarchy 
[2016-07-15 11:01:44.692] boot - 14956 INFO [Thread-4] --- DefaultLifecycleProcessor: Stopping beans in phase 0 
[2016-07-15 11:01:44.752] boot - 14956 INFO [Thread-4] --- AnnotationMBeanExporter: Unregistering JMX-exposed beans on shutdown 
[2016-07-15 11:01:44.810] boot - 14956 INFO [Thread-4] --- LocalContainerEntityManagerFactoryBean: Closing JPA EntityManagerFactory for persistence unit 'default' 

Anche qui allegato screenshot.

enter image description here

prega di guida, Grazie.

+0

Prendere un dump di thread utilizzando il comando kill -3 , in modo da ottenere più chiarezza ciò che sta accadendo sotto. –

+2

Immagino che sia il killer di memoria esaurito di Linux che sta fermando il processo. Questo ti aiuterà a capire se questo è il caso: http://stackoverflow.com/questions/624857/finding-which-process-was-killed-by-linux-oom-killer#624868 –

risposta

3

Se si utilizza Maven aggiungere questo alla tua pom.xml

<dependency> 
    <groupId>org.springframework.boot</groupId> 
    <artifactId>spring-boot-starter-web</artifactId> 
</dependency> 

Dovrebbe funzionare.

+0

Ciao bar, questa dipendenza è già nel mio pom.xml. –

+0

scusa per il ritardo. quindi forse la ram del sistema ha causato questo. Quanta RAM hai e qual è il carico? –

+0

Ciao, Inizialmente utilizzo il server spaziale 512mb, quindi mi sposto in 2gb, quindi funziona bene ora. –

Problemi correlati