2016-07-03 3 views
5

L'ultima versione di Google Play Services è Google 9.2.0 Tuttavia Android di emulatore di Play Services è solo 9.0.80Android emulatore ha obsoleto Google Play Services

Di conseguenza, non è possibile eseguire un app compilato con 9.2.0 sull'emulatore. Ad esempio, MapView mostra che questa app non può essere eseguita. Si prega di aggiornare Google Play Services"

Qualsiasi soluzione diversa da cambiare le dipendenze di applicazioni a 9.0.2?

+3

Ho notato che l'API 23 "API x86 Atom System Image API di Google" era Rev 12 e aggiornata a Rev 14 e ha ancora 9.0.80. La mia ipotesi è che dobbiamo aspettare che una nuova immagine sia rilasciata con 9.2.0 installato. Non sono riuscito a trovare alcuna nota di rilascio sulle immagini dell'emulatore. Sarebbe bello se le nuove immagini fossero rilasciate in tandem con Google Play Services. – jenglert

+1

Le immagini dell'emulatore sono state aggiornate oggi. Ora ha google play services 9.2.56 Sto usando X86_API23 – Sreekanth

risposta

-1

Aggiungi Google Play Services per il vostro progetto, aggiungere dependencies per l'ultima versione di play-services.

apply plugin: 'com.android.application' 
... 

dependencies { 
compile 'com.google.android.gms:play-services:9.2.0' 
} 

Assicurati di aggiornare questo numero di versione ogni volta che vengono aggiornati i servizi di Google Play.

Come descritto nello Google Play services overview, Google Play offre aggiornamenti di servizio per gli utenti su Android 2.3 e più in alto tramite l'app Google Play Store. Tuttavia, gli aggiornamenti potrebbero non raggiungere immediatamente tutti gli utenti, quindi la tua app dovrebbe verificare la versione disponibile prima di tentare di eseguire transazioni API.

Si consiglia vivamente di utilizzare la classe GoogleApiClient per accedere alle funzioni dei servizi di Google Play. Questo approccio consente di allegare un oggetto OnConnectionFailedListener al client. Per rilevare se il dispositivo ha la versione appropriata dell'APK dei servizi di Google Play, implementa il metodo di callback onConnectionFailed(). Se la connessione non riesce a causa di una versione mancante o obsoleta dell'APK di Google Play, la richiamata riceve un codice di errore come SERVICE_MISSING, SERVICE_VERSION_UPDATE_REQUIRED o SERVICE_DISABLED.

+2

stai confondendo la libreria di Google Play Service e l'app di Google Play Services sull'emulatore. L'intero punto è che se si aggiunge la dipendenza 9.2.0, l'emulatore non funziona. –

Problemi correlati