2016-07-15 3 views
6

Dopo aver cercato di ricreare un ambiente utilizzando un file ho ottenuto questo errore: Error: Packages missing in current osx-64 channels: - timbr-io::argh 0.26.1 py27_0 - timbr-io::pathtools 0.1.2 py27_0 - timbr-io::watchdog 0.8.3 py27_0 pacchetti mancanti nella corrente osx-64 e canali

E lo stesso errore in esecuzione di tali comandi su un contenitore finestra mobile. Error: Packages missing in current linux-64 channels: - timbr-io::argh 0.26.1 py27_0 - timbr-io::pathtools 0.1.2 py27_0 - timbr-io::watchdog 0.8.3 py27_0

Questo è il file che sto utilizzando come fonte: name: snowflakes dependencies: - boto3=1.3.1=py27_0 - botocore=1.4.28=py27_0 - docutils=0.12=py27_2 - ecdsa=0.13=py27_0 - futures=3.0.5=py27_0 - jmespath=0.9.0=py27_0 - openssl=1.0.2h=1 - paramiko=1.16.0=py27_0 - pip=8.1.2=py27_0 - pycrypto=2.6.1=py27_4 - python=2.7.12=1 - python-dateutil=2.5.3=py27_0 - pyyaml=3.11=py27_4 - readline=6.2=2 - setuptools=23.0.0=py27_0 - six=1.10.0=py27_0 - sqlite=3.13.0=0 - timbr-io::argh=0.26.1=py27_0 - timbr-io::pathtools=0.1.2=py27_0 - timbr-io::watchdog=0.8.3=py27_0 - tk=8.5.18=0 - wheel=0.29.0=py27_0 - yaml=0.1.6=0 - zlib=1.2.8=3 - pip: - argh==0.26.1 - pathtools==0.1.2 - watchdog==0.8.3

Nota: Io in realtà creare questo file eseguendo i seguenti comandi, il problema è quando provo a ricreare questo ambiente. conda create --name snowflakes boto3 paramiko source activate snowflakes conda install -c timbr-io watchdog conda env export > environment.yml

Come potete vedere sto installando watchdog da timbr-io (in anaconda.org), che hanno linux-64 e osx-64 versioni di esso (timbr-io/watchdog).

risposta

4

Non è possibile utilizzare un ambiente conda esportato da un sistema operativo e utilizzarlo su un altro.

I numeri di pacchetto (e in alcuni casi l'esistenza del pacchetto) non sono allineati su piattaforme diverse.

conda env export è così è possibile riprodurre lo stesso ambiente su quello stesso SO.

Problemi correlati