2016-05-11 8 views
8

per l'installazione all'interno di una finestra mobile, sia vim o nano ma ho solo ottenere questo:Impossibile installare vim o nano all'interno del contenitore finestra mobile

0% [Connecting to archive.ubuntu.com (91.189.88.152)] 

Exit finestra mobile e fare ping archive.ubuntu.com e ottengo risposta, fare lo stesso tempo all'interno della finestra mobile non risponde.

Quale potrebbe essere il problema?

+0

Come stai cercando di installare vim o nano? –

+0

L'ho installato con 'apt-get install nano' e ha funzionato. Potrebbe essere necessario eseguire 'apt-get update' prima. –

+0

@ 洋葱 头 anche 'apt-get update' non funziona allo stesso modo 0% – xybrek

risposta

2

La soluzione è quella di eseguire finestra mobile con:

docker run --net=host 
16

prima cosa creare il finestra mobile:

sudo docker run -t -i ubuntu /bin/bash 

Invece di questo si può inserire in una finestra mobile in esecuzione con il suo numero o il nome:

sudo docker exec -it be8aa338d656 bash 

Poi all'interno della finestra mobile eseguire questo codice:

apt-get update 
apt-get install vim nano 
+0

Bloccato qui: 'gpg: chiave di richiesta EEA14886 dal server hkp keyserver.ubuntu.com' – xybrek

+0

una volta che ho un problema simile. Aggiorno la finestra mobile all'ultima versione e risolve tutto.Ho Docker versione 1.11.1 – Troncador

+0

Ho avuto problemi nel tentativo di accedere al percorso al di fuori della rete del docker, ma l'aggiornamento risolve il mio problema – Troncador

1

Sembra che la finestra mobile non sia in grado di connettersi a Internet. Prova questo: -

sysctl -w net.ipv4.ip_forward=1 

quindi riavviare: -

service docker restart 

Se ancora non funziona, leggi qui: - My docker container has no internet

+0

questo errore: '' 'root @ appscale2: ~ # sysctl -w net.ipv4.ip_forward = 1 - net.ipv4.ip_forward = 1 sysctl: "-" deve essere il nome del modulo = value''' – xybrek

+0

Sto usando Ubuntu 14.04 – xybrek

+0

Spiacente c'è un errore di battitura, è necessario saltare quel "-" all'ultimo. Ho modificato i miei ans. –

0

Assolutamente senza fortuna con apt o apt-get. La finestra mobile che sto utilizzando da qualcun altro non sembra avere le origini/etc/apt configurate corrette (o disabilitate). Devo modificare le configurazioni.

Fortunatamente dpkg e arricciatura sono disponibili all'interno del contenitore. Ho usato i binari per il mio amd64. https://launchpad.net/ubuntu/+source/vim/2:7.4.712-2ubuntu4

mkdir/tmp/vim cd/tmp/vim

ricciolo http://launchpadlibrarian.net/221875822/vim_7.4.712-2ubuntu4_amd64.deb> vim.deb ricciolo http://launchpadlibrarian.net/221873815/vim-common_7.4.712-2ubuntu4_arm64.deb> vim-common.deb ricciolo http://launchpadlibrarian.net/221875814/vim-runtime_7.4.712-2ubuntu4_all.deb> vim-runtime.deb ricciolo https://launchpad.net/ubuntu/wily/amd64/vim/2:7.4.712-2ubuntu4> vim .deb ricciolo http://mirrors.kernel.org/ubuntu/pool/main/g/gpm/libgpm2_1.20.4-6.1_amd64.deb> libgpm2.deb

dpkg -i * .deb

non è il miglior modo lution, ma almeno ora posso modificare i file di configurazione.

Problemi correlati