2013-02-27 1 views
8
02-28 01:49:27.741: E/AndroidRuntime(23024): FATAL EXCEPTION: main 
    02-28 01:49:27.741: E/AndroidRuntime(23024): java.lang.RuntimeException: Unable to instantiate activity ComponentInfo{com.appname.android/com.appname.android.ITCutiesReaderAppActivity}: java.lang.ClassNotFoundException: Didn't find class "com.appname.android.ITCutiesReaderAppActivity" on path: /data/app/com.appname.android-2.apk 
    02-28 01:49:27.741: E/AndroidRuntime(23024): at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2106) 
    02-28 01:49:27.741: E/AndroidRuntime(23024): at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2230) 
... 
    02-28 01:49:27.741: E/AndroidRuntime(23024): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:793) 
    02-28 01:49:27.741: E/AndroidRuntime(23024): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:560) 
    02-28 01:49:27.741: E/AndroidRuntime(23024): at dalvik.system.NativeStart.main(Native Method) 
    02-28 01:49:27.741: E/AndroidRuntime(23024): Caused by: java.lang.ClassNotFoundException: Didn't find class "com.appname.android.ITCutiesReaderAppActivity" on path: /data/app/com.appname.android-2.apk 
    02-28 01:49:27.741: E/AndroidRuntime(23024): at dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:65) 
    02-28 01:49:27.741: E/AndroidRuntime(23024): at java.lang.ClassLoader.loadClass(ClassLoader.java:501) 
    02-28 01:49:27.741: E/AndroidRuntime(23024): at java.lang.ClassLoader.loadClass(ClassLoader.java:461) 
    02-28 01:49:27.741: E/AndroidRuntime(23024): at android.app.Instrumentation.newActivity(Instrumentation.java:1054) 
    02-28 01:49:27.741: E/AndroidRuntime(23024): at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2097) 
    02-28 01:49:27.741: E/AndroidRuntime(23024): ... 11 more 

Ho iniziato a ricevere questo errore dopo aver eliminato la cartella extra nella cartella app con gli stessi file app (e modificato il nome dell'app, i nomi fissi in tutti i file). Come posso risolvere questo?android ClassNotFoundException: Non ha trovato la classe

Ecco manifest.xml

<?xml version="1.0" encoding="utf-8"?> 
<manifest xmlns:android="http://schemas.android.com/apk/res/android" 
    package="com.appname.android" 
    android:versionCode="3" 
    android:versionName="1.0" > 
    <uses-sdk android:minSdkVersion="7" /> 
    <uses-permission android:name="android.permission.INTERNET"/> 
    <application 
     android:icon="@drawable/ic_launcher" 
     android:label="@string/app_name"> 
     <activity 
      android:name=".ITCutiesReaderAppActivity" 
      android:label="@string/app_name" > 
      <intent-filter> 
       <action android:name="android.intent.action.MAIN" /> 
       <category android:name="android.intent.category.LAUNCHER" /> 
      </intent-filter> 
     </activity> 
     <activity 
      android:name=".ItemDescriptionActivity" 
      android:label="@string/app_name" > 
      <intent-filter> 
       <action android:name="android.intent.action.MAIN" /> 
      </intent-filter> 
      </activity> 
    </application> 
</manifest> 
+0

Pubblica il tuo manifest così possiamo ricontrollare, ma potresti semplicemente aver bisogno per pulire il tuo progetto ed eseguirlo di nuovo. – Sam

+0

Aggiunto alla domanda. – milesh

+0

@milesh Sembra che il nome del pacchetto non corrisponda, è 'com.appname.android' il pacchetto della tua app? –

risposta

17

È fare hanno un errore di pacchetto di mancata corrispondenza, ha bisogno di essere:

package="com.haber29.android.reader" 

Dal reader è la prossima subpackage e questo è il subpackage che contiene le attività.

E non dimenticate, è possibile specificare il nome completo per ogni attività, per evitare confusione:

<?xml version="1.0" encoding="utf-8"?> 
<manifest xmlns:android="http://schemas.android.com/apk/res/android" 
    package="com.haber29.android" 
    android:versionCode="3" 
    android:versionName="1.0" > 
    <uses-sdk android:minSdkVersion="7" /> 
    <uses-permission android:name="android.permission.INTERNET"/> 
    <application 
     android:icon="@drawable/ic_launcher" 
     android:label="@string/app_name"> 
     <activity 
      android:name="com.haber29.android.reader.ITCutiesReaderAppActivity" 
      android:label="@string/app_name" > 
      <intent-filter> 
       <action android:name="android.intent.action.MAIN" /> 
       <category android:name="android.intent.category.LAUNCHER" /> 
      </intent-filter> 
     </activity> 
     <activity 
      android:name="com.haber29.android.reader.ItemDescriptionActivity" 
      android:label="@string/app_name" > 
      <intent-filter> 
       <action android:name="android.intent.action.MAIN" /> 
      </intent-filter> 
      </activity> 
    </application> 
</manifest> 
0

Ho lo stesso problema di oggi, perché la mia biblioteca includono l'androide-supporto-v4. jar non corrisponde alla mia demo Eliminare la libreria-android-support-v4.jar e copiare il jar del mio demo mettendolo nella mia libreria, inizia il lavoro

Problemi correlati