2016-01-15 7 views
12

Ricevo questo errore quando eseguo o eseguo il debug dell'applicazione ma quando compilo o pulisco il mio progetto non ci sono errori. Sembra strano ma ho perso le mie 4-5 ore alla ricerca di questo, ma nulla è stato utile. Errore:google play services 8.4.0 - classes.jar non trovato - android studio

Error:Execution failed for task ':app:compileDebugJavaWithJavac'.> java.io.FileNotFoundException: C:\Users\Saeed Jassani\Downloads\AppName\app\build\intermediates\exploded-aar\com.google.android.gms\play-services\8.4.0\jars\classes.jar (The system cannot find the path specified) 

file di build.gradle:

apply plugin: 'com.android.application' 

android { 
compileSdkVersion 23 
buildToolsVersion "23.0.2" 
defaultConfig { 
    applicationId "com.example.app" 
    minSdkVersion 9 
    targetSdkVersion 23 
    versionCode 1 
    versionName "1.0" 
} 
buildTypes { 
    release { 
     minifyEnabled false 
     proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' 
    } 
} 
} 
dependencies { 
compile fileTree(dir: 'libs', include: ['*.jar']) 
testCompile 'junit:junit:4.12' 
compile 'com.android.support:appcompat-v7:23.1.1' 
compile 'com.android.support:recyclerview-v7:23.1.1' 
compile 'com.android.support:design:23.1.1' 
compile 'com.google.android.gms:play-services:8.4.0' 
compile 'com.android.support:support-v4:23.1.1' 
} 
+2

stesso qui. Ho aggiornato i repository di google, ma il problema non si risolve. –

+0

sì ... ho anche aggiornato tutte le cose possibili ma il problema persiste .. Se qualcuno può aiutare allora sarà davvero utile –

+0

Penso che il problema sia con la directory del progetto in quanto contiene uno spazio 'C: \ Users \ Saeed Jassani \ Download ... '. Prova a spostare il tuo progetto in una directory diversa. –

risposta

16

È possibile risolvere questo problema utilizzando alpha6:

repositories { 
    mavenCentral() 
    jcenter() 
} 
dependencies { 
    classpath 'com.android.tools.build:gradle:2.0.0-alpha6' 
} 
1

pulire il vostro progetto e aggiungere seguenti dipendenze nella vostra costruzione livello di progetto. gradle file

dependencies { 

     classpath 'com.android.tools.build:gradle:2.0.0-alpha6' 

     classpath 'com.google.gms:google-services:2.0.0-alpha6' 

    } 
+0

Prima di tutto, il plugin gradle per Android deve essere specificato nel file ** build.gradle ** a livello di progetto. Quindi, la dipendenza 'google-services' dovrebbe essere specificata in ** build.gradle ** dell'app. Dovrebbero essere due file separati? –

Problemi correlati